Backup Performance

Incident Report for m107

Monitoring

A fix has been successfully implemented and the backup jobs are currently running as expected. We will continue to closely monitor the situation to ensure ongoing stability
Posted Oct 16, 2025 - 08:21 UTC

Investigating

We are currently investigating an issue causing degraded backup performance, which may impact your service level agreement (SLA). Our engineering team is actively working to identify the root cause and implement a resolution. We will provide updates as more information becomes available.
Thank you for your patience.
Posted Oct 15, 2025 - 23:24 UTC
This incident affects: Dynamics 365 (Switzerland North, West Europe, South Africa North, France Central), File & Object (West Europe, North Europe, France Central, Switzerland North, South Africa North), Office 365 (Switzerland North, France Central, South Africa North, West Europe), VM & Kubernetes (North Europe, France Central, South Africa North, Switzerland North, West Europe), Database (South Africa North, France Central, Switzerland North, West Europe), SalesForce (West Europe, Switzerland North, France Central, South Africa North), Endpoint (France Central, South Africa North, West Europe, Switzerland North), and Active Directory (Switzerland North, France Central, South Africa North, West Europe).