Degraded O365 job performance

Incident Report for m107

Identified

We continue to work closely with Microsoft to address the issue impacting backup performance. While mitigation efforts remain underway, some Office 365 backup jobs may continue to experience delays due to the access node outage. Our engineering teams are actively engaged and monitoring progress to restore normal performance as quickly as possible. We appreciate your patience and understanding and will provide another update once service performance has been fully restored.
Posted Jul 31, 2026 - 14:25 UTC

Investigating

We are currently experiencing degraded backup performance impacting some Office 365 backup jobs due to an access node outage. Our engineering team is working closely with Microsoft to resolve the issue and restore normal operations as quickly as possible. We appreciate your patience and understanding while we work toward full resolution.
Posted Jul 29, 2026 - 12:39 UTC
This incident affects: Office 365 (West Europe).